Gradle derleme hatası


#1

Arkadaşlar merhabalar, toga kütüphanesi ile hazırlanmış programı apk olarak derlemeye çalışıyorum aldığım hata şudur, nerede hata veya eksik yapıyorum anlamadım, bu gradle gerçekten çok büyük sıkıntı :

* What went wrong:
Execution failed for task ':transformClassesWithDexBuilderForDebug'.
> com.android.build.api.transform.TransformException: com.android.builder.dexing.DexArchiveBuilderException: com.android.builder.dexing.DexArchiveBuilderException: Failed to process /home/mypcs/tutorial_0/android/build/intermediates/transforms/desugar/debug/0

build.gradle dosyamın içeriği

buildscript {
    repositories {
        jcenter()
        google()
    }

    dependencies {
        classpath 'com.android.tools.build:gradle:3.1.0'
    }
}

task buildPythonDebug << {
    exec {
        commandLine "voc -v -p app -o build/intermediates/classes/debug app".split()
    }
    exec {
        commandLine "voc -v -p app_packages -o build/intermediates/classes/debug app_packages".split()
    }
}

task buildPythonRelease << {
    exec {
        commandLine "voc -v -p app -o build/intermediates/classes/release app".split()
    }
    exec {
        commandLine "voc -v -p app_packages -o build/intermediates/classes/release app_packages".split()
    }
}

task run << {
    exec {
        commandLine "adb shell am start -n com.example.tutorial_0/android.Tutorial".split()
    }
}

apply plugin: 'com.android.application'

android {
    compileSdkVersion 25
    buildToolsVersion "25.0.2"

    defaultConfig {
        minSdkVersion 15
        targetSdkVersion 25
        versionCode 1
        versionName "1.0"
        multiDexEnabled true
    }
    packagingOptions{
        exclude 'META-INF/rxjava.properties'
    }
    dexOptions {
        javaMaxHeapSize "4g"
    }
    compileOptions {
        sourceCompatibility JavaVersion.VERSION_1_8
        targetCompatibility JavaVersion.VERSION_1_8
    }
    sourceSets {
        main {
            manifest.srcFile 'AndroidManifest.xml'
            java.srcDirs = ['src']
            res.srcDirs = ['res']
        }
    }
}

project.afterEvaluate {
    packageDebug.dependsOn buildPythonDebug
    packageRelease.dependsOn buildPythonRelease
    run.dependsOn installDebug
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    compile 'com.android.support:appcompat-v7:25.1.1'
    compile 'com.android.support:multidex:1.0.1'
    implementation 'com.google.auto.value:auto-value-annotations:1.6'
    annotationProcessor 'com.google.auto.value:auto-value:1.6'
}

allprojects {
    repositories {
        jcenter()
        maven {
            url "https://maven.google.com"
        }
    }
}

gradle.properties içeriği

org.gradle.jvmargs=-Xmx1536M
android.enableD8=true

#2

Yüksek ihtimalle sürümlerde sıkıntı var, Java sürümü gibi.


#3

@coderistan ilgilendiğin için çok teşekkürler, bir de sürümleri güncelleyip öyle deneyim.