Linüx Ubuntu kivy yükleme sorunu


#1

Yukarıdaki siteden Linüx Ubuntuya kivy’i kurmaya çalışdım ama biryerde sorun çıkdı. İlk başda yükledim hatta hepsini yükledi sonra en sonda gine aynı çıktıyı veri bida denedim indirdi gözüküyor ama en sonda hata veriyor.(python3)


#2

Aşağıdaki başlığı siz açmıştınız, neden o başlıkta anlatılan adımları takip etmiyorsunuz?


#3

ordaki python 2 degilmi?


#4

Python2 için ancak Python3 ile android uygulama derleme işlemi hala deneysel olarak destekleniyor. O başlıkta da belirtmiştim. Python3.5 için bir apk derleyebilmiştim daha önce. Ama Python3.6 için apk derleme işlemi Python3.5’de olduğu gibi olmuyor. Siz Ubuntu’nun 18.04 sürümünü kullanıyorsunuz. Otomatik olarak Python3.6 kurulu olarak geliyor.
Kivy’yi Python3 ile kullanmaya çalışmanız beklemediğiniz hatalar almanıza neden olabilir. Yine de siz bilirsiniz.


#5

peki python 3.5 ile kursam :slight_smile:


#6

Peki bir deneyin isterseniz. Ama python3.5’in kaynak dosyalarını indirmeniz gerekecek.


#7

zaten sorunum o nasıl yükleyebilirim kivy python 3.5 ile. (bide ubuntuyu yeni kullanıyorum :slight_smile: )


#8

Ubuntu 18.04’de Python3.6 kullanılıyor. Python’ın eski sürümlerini terminalden indiremezsiniz. Eğer eski bir sürümü kullanmak istiyorsanız, eski sürümün kaynak dosyalarını Python’ın resmi sayfasından indirmeniz gerekir.

Zamanında aşağıdaki başlıkta Python3.5’de nasıl apk derleneceği ile alakalı izlediğim yolları paylaşmıştım.

Ancak zaman içinde Python2 için bile bir takım değişiklikler söz konusu olmuş. Mesela buildozer’in yeni sürümü yayınlandıktan sonra kurulum hataları oluşmaya başlamış. Başlığı incelediğinizde ve sizin açtığınız başlığa yazdığım adımlar ile karşılaştırdığınızda, adımların farklı olduğunu göreceksiniz. Yani demek istediğim şu, vakti zamanında takip ettiğim bir işlem sırası, yarın geçerli olmayabilir.

Mesela Ubuntu 18.04 çıktıktan sonra 18.04’e geçtim, otomatik olarak Python3.6 kullanmaya başladım. Ama kivy de sorun oluşturduğu için Python3.5’e dönmek istedim ve kaynak dosyasını indirdim, kurdum. Ama Ubuntu 17.04’de apk derleyebildiğim gibi apk derleyemedim, hatalar aldım. Size bu yüzden şimdilik Python2 kullanın diyorum. Bu arada belki forumda bazı arkadaşlar Python3.6 kullanarak nasıl apk derleyebildiklerini adım adım anlatabilirler. Veya ileride bu konuda bir gelişme olursa forumda yine paylaşılır diye düşünüyorum.


#9

Saolun cevap için size de zahmet verdim. :slight_smile: python 2 yi kullanmaya karar verdim.

benim sistemimde python2 ve python3 yüklüymüş :smile:


#10

Estafurullah ne zahmeti…
Ubuntu’da her iki majör Python sürümü de yüklü.


#11

Birşey sormayı unuttum, ben bu pythonu kullanmak için sürekli terminalimi açıçam bu IDE yi nasıl kurabalirim acaba?. :slight_smile:


#12

Python3 için aşağıdakini yazın:

sudo apt-get install idle3

Python2 için ise aşağıdakini yazın:

sudo apt-get install idle

#13

şuan hepsini kurdum :slight_smile:


#14

Python2 ile bir apk derlemeye çalışın, eğer hata alırsanız, ister https://forum.yazbel.com/t/python-kivy-paketleme-islemi başlığında, ister bu başlıkta hatanın çıktısını paylaşın.


#15

Tamam paylaşırım, birde ben grafik için Sublime Text kullanıyorum sizin bana önerebileceginiz başka bir GUI varmı ?


#16

Kullandığım metin düzenleyiciler değişiyor. Bazen gedit kullanıyorum bazen vim kullanıyorum. Bazen de pycharm-community (ide) kullanıyorum.


#17

pycharm inidip kurarsam kivy otomatik mi yüklencek ben mi yükliyicem?

(vim’in arayüzüne bakdım ve hoşuma gitti onu kullabilirim. :slight_smile: )


#18

Pycharm’ın kivy ile bir alakası yok zaten. Kivy için daha önce açtığınız başlıkta yazdığım adımları takip edin.


#19

anladım Teşşekürler… :blush:


#20

Rica ederim, kolay gelsin.