Opencv yükleyemiyorum

Merhaba. Python 3.7 için openvc 4.1.0 ı pip install kullanarak indirdim. İndirme başarılı mesajını aldım. Ancak import cv2 yazdığımda, “böyle bir modül bulunamadı” hatasını aldım. Dosya yolunda, python içindeki bütün klasörlere baktım, windows gezgini ile arattım, open cv veya opencv-python veya cv2 diye bir dosya yok. Yeniden yükledim; “zaten var” deyip dosya yolu veriyor, python\lib\site-packages olarak, ama o klasörde opencv yok. Aynı şeyler numpy için de geçerli.
Daha önce anaconda ile de indirememiştim. Bir tam gün uğraşıp başaramayınca, sinirlenip anaconda’yı bilgisayarımdan kaldırdım. Çünkü spyder ve jupiter de sık sık hata veriyordu. İşletim sistemim windows 7.
Python’da her kütüphane veya eklenti için böyle sorunlar yaşanıyor mu, yani forumlardan anladığıma göre versiyon veya işletim sistemi uyumsuzlukları pythonda standart gibi. ne yapmalıyım? c++ veya java mı öğrenmeliyim? Yardım lütfen!

Windows yüzünden Python bırakılır mı :smile:

Komut istemini yönetici olarak çalıştırdıktan sonra deneyin. Ama önce;

pip uninstall <moduladi>

Komutunu çalıştırın. Ayrıca yüklerken gelen çıktıları da paylaşın.

Benim tavsiyem, bir zorunluluğunuz yok ise linux’e geçin, rahat edin!

Öncelikle merhabalar, Windows sürümünüzü stabil hale getirdikten sonra öyle modül indirdiğinizde sorun çıkmaz aynı şekilde bazen linux de bu hataları verebiliyor could not find diyor bulamıyor o package yi indirdiğinizde bağımlılık hataları veriyor o yüzden her işletim sisteminde bu tarz şeyler olabilir önemli olan çözmek pes etmeyin :slight_smile:
ve hiç merak etmeyin python da böyle bir sorun varsa java ve c++ dillerinde de vardır illaha bir şeyler :slight_smile:

İlginize teşekkürler. Daha önce mysql bağlantısı için de günlerce uğraşmış, tesadüfen çözmüştüm. O yüzden birikti sanırım içimde birşeyler. opencv için, python 3.7 sorun yaratabiliyor, 3.6 kurun deniyor bazı forumlarda. Python 32, 64, python 3.7, var zaten, şimdi bir de 3.6 aradım bulamadım, 3.5 var görünüyor. eski sürümleri silmeye korkuyorum, çalışmalarımı kaybedebilirim diye. Bilgisayarım python ve modül kalabalığı ile dolacak.
Komut sistemini zaten yönetici olarak çalıştırıyorum. Bazı şeyleri uninstal edersem yazdığım kodları çalıştıramayabilirim diye korkuyorum(yeni yükleyeceğim modüllerde uyumsuzluk korkusu. Daha önce bir kere yaşadım, çalışan bir fonksiyonum bu tür değişiklikten sonra çalışmadı, yeniden yazmak zorunda kaldım)
Linux gerçekten bu sorunları çözüyor mu?

Windows sürümünü stabil hale getirmek ne demek? Güncellemeleri mi kastediyorsunuz?

Hayır yani şöyleki bildiğiniz gibi bazı bağımlılıklar var linuxde de bu bağımlılıkları yüklerken bazen hata veriyor şu bağımlılık şuna çakışıyor gibi bu bağımlılıkları yükledikten sonra başarılı bir şekilde çoğu yeni modülde yeni hata ile karşılaşmıyorsunuz yani windowsda bir işi çözdükten sonra diğer modül içinde bir işi başarmış olursunuz aynı şekilde linux içinde geçerli

Özür dilerim Asosyal_Futbolcu, benim bilgisayar eğitimim yok, alaylıyım, internet ve wsword kullanacak kadar bilgisayar bilgim var(mesela dos bilmiyorum) ve 65 yaşında programlama öğrenmeye başladım. Bağımlılıklar nedir ve bağımlılıklar nasıl yüklenir bilmiyorum. Öğrenebileceğim şekilde yazarsanız minnettar kalırım.

Aslında şurayı okursanız linux hakkında çok bilgi edinmiş olursunuz yani bağımlılık nedir öğrenirsiniz

https://e-bergi.com/y/linuxta-paket-yonetim-sistemleri/

Teşekkür ederim, bilgilendirici, ama sorunu çözmek için çabalamaya devam etmem gerekiyor hala.

Arkadaşlar Raspberry Pi3+ kullanıcısıyım.Opencv yi adım adım kurmaya çalışıyorum.Sisten güncel ve son sürüm ancak indiriyorum Opencv dosyasını belirtilen yapılandırmaları yapıyorum kurulumda %83de sürekli hata veriyor.Fanda takıp denedim yine aynı yardımlarınızı bekliyorum tşklr.

Bu konuyu yeni bir baslik olarak acip altina takip ettigin adimlari ve aldigin hatalari yazman lazim.