PyQt5 kurulumunda hata alıyorum

PyQt5 i internetten indirdim. Fakat PyCharmda import edemiyorum.İnternetten çözümlere baktım. Biri terminale pip3 install pyqt5 komutunu verince oluyormuş. Fakat bunu yapınca
şu hatayı alıyorum:
Could not build wheels for PyQt5-sip which use PEP 517 and cannot be installed directly

Yardım ederseniz çok sevinirim 3 gündür bununla uğraşıyorum kafayı yiyeceğim.

PyCharm -> file -> settings -> project:‘your_project’ - project interpreter -> + -> install PyQt5

Şeklinde yüklemeyi deneyin istiyorsanız. Olmazsa buradaki çözümleri inceleyebilirsiniz:

her iki şekilde de yaptım ama bi türlü olmuyor

site packages de PyQt5 var

Pycharm kullanmadığım için bir şey diyemiyorum, ben de verdiğim linki incelemiştim. İmport işlemi için bu kodu kullanıyorsunuz değil mi?

import PyQt5

Evet bu kodu kullanıyorum.

Pycharm’da kullanmak için import Pyqt5 dedikten sonra fare imlecini pyqt5 yazısının üstüne getirin. Kırmızı ya da sarı ampul çıkacaktır ona tıklayın. install pyqt5 yazısı çıkacak buna tıklayın ve pyqt5 tanımlansın. Ayrıca python 3.5 sürümünü kullanırsanız daha güzel olur

PyCharm terminaline (galiba Anaconda Prompt olarak geçiyor) pip install pyqt5 yazarsanız sorun çıkmamalı.