PyQt5 Qt platform plugin hatası

hatanın ss i bu pyqt5

bu hatayı bu kodlardan aldım

from PyQt5.QtWidgets import *
import sys


class QtMainWindow(object):
    pass


def ana_pencere(args):
    pass


class Ana_pencere(QtMainWindow):
    def __init__(self):
        super(ana_pencere, self).__init__()


ana_uygulaması = QApplication(sys.argv)


def ana_pen():
    pass


Ana_pencere = ana_pen()


class Ana_penceresi(object):
    pass


Ana_penceresi.show()
ana_uygulaması.exec()

@Oguz_Turkyilmaz da bu hatayı almıştı.

Sonradan çözülmüş

abi peki benim konum daha var ona bakar msın @Unnick PİP neden PyCharm da Gözükmüyor Yardım

Anaconda mı kullanıyorsun sen ?

düz python kullanıyorum

o zaman bana Python’un içinde kurulu olan yolu gösterir misin.

Bende de normal bir şekilde kurullmuşu var mesela.

Sen de burayı bulup Lib klasörünün içinde pipten kurduğun şeyin bulunup bulunmadığını kontrol eder misin.

iniyor pyqt5designer

libdeyim abi şimdi ne yapmalıyım

pip ile ne indirdiysen onun Lib’de bulunup bulunmadığını kontrol et

tamam PyQt5 i aratcam o zmn

var abi pyqt5 klasorü @Unnick

cmd’den pip install ile pyqt5’i indirdiğinde ne yazıyor görebilir miyim?

abi pyqt5 designer da indi

Microsoft Windows [Version 6.3.9600]
(c) 2013 Microsoft Corporation. Tüm hakları saklıdır.

C:\Users\Güçlü>pip install PyQt5Designer
Collecting PyQt5Designer
  Downloading PyQt5Designer-5.14.1-py3-none-win_amd64.whl (40.8 MB)
     |████████████████████████████████| 40.8 MB 14 kB/s
Installing collected packages: PyQt5Designer
Successfully installed PyQt5Designer-5.14.1

al abi bana bunu veriyor

C:\Users\Güçlü>pip install PyQt5
Requirement already satisfied: PyQt5 in c:\users\güçlü\appdata\local\programs\py
thon\python38\lib\site-packages (5.15.1)
Requirement already satisfied: PyQt5-sip<13,>=12.8 in c:\users\güçlü\appdata\loc
al\programs\python\python38\lib\site-packages (from PyQt5) (12.8.1)

@Unnick abi bak

designer ile ilgili olarak attığım konuyu takip et.

buraya bakarak bir cevap bulmaya çalışabilirsin. Buradan fazlası da yok bende

Pyqt5’i VS code programında import ettiğinde çalışıyor mu peki ?

Pycharm var bende sadece sildim vs code yi

Pycharmda python 3.8’İ kullandığından emin misin peki ?

Çünkü pyqt5 3.8’e iniyor.

Pycharmda başka python sürümü kullanıyorsan belki o yüzden import edemiyor olabilirsin.

abi 3 8 3 var bende python sürümü